Self Install Login Issue

Hi
I have installed the application on a testing linux server prior to trying to use in production. Its a Centos 7 server and have followed the sub-directory instructions but I can seem to land on a login page.
I have setup the redirect changes and get the install screen which I can see writes to the database but when I login after the install success page entering the prior steps email/password, the page just seems to refresh itself and wants me to login again.
If i use an incorrect password, i get the wrong password error so its communicating to the database, but i cant seem to “Login” and see the initial page.
Any ideas?

Thanks

I attempted to login this morning and for some reason, it worked.
I didn’t change any settings or perform any server reboots so not sure what caused the errors last night.
Anyway, I see the “take the full tour” screen now and can try it out.

Hey, glad it worked out.

I have the exact same issue.
Logins fail – if the password is wrong, I’ll get a notification though – so I have the right password.

It took me a long time to actually get here, because I have leantime setup like this:

  • /var/www/virtual/$USER/lean – contains the latest stable release
  • https://lean.domain.tld is the subdomain and directs to the /public folder (/var/www/virtual/$USER/lean/public).
    Now, the .htaccess file in /public says (I suck at .htaccess files ;)):

#Uncomment and update if Leantime runs in a subfolder
RewriteEngine On
RewriteBase /

The error log doesn’t seem to show anything relevant:

[01-May-2020 23:22:33 America/Los_Angeles] PHP Notice: Undefined index: companysettings.logoPath in /var/www/virtual/$USER/lean/src/core/class.mailer.php on line 96
[01-May-2020 23:22:33 America/Los_Angeles] PHP Notice: Undefined index: companysettings.mainColor in /var/www/virtual/$USER/lean/src/core/class.mailer.php on line 97

Any suggestions, what the error could be?
thanks a lot!
F

This seems unrelated to me. The error message states that a few session indexes aren’t set. There are a few options why that would be the case.

The fact that you can attempt to login and verify the password seems to support that as well.

My first guess would be to check if your PHP instance can write to the session path folder.

Second is to check if you have cookies enabled.

Third, when you try to login, check your database table zp_user and verify that a session column is set.

Wow, thanks for the quick thorough reply, very cool!
I did a quick check so far:

  1. Sessions Path folder – hmmm, that I have no clue, honestly – it’s shared hosting, I never had an issue with that, but I’ll check,
  2. Cookies: are enabled – I checked Firefox, Chrome and Safari, same effect everywhere.
  3. zp_user session column set. How do I know it is set? It doesn’t seem like it – screenshot of the only user after installation, immediately after trying to login. Screenshot 2020-05-02 at 18.48.49

Thanks. From your screenshot it seems the session id has not been set.
Can you check your PHP ini to see if [session.strict_mode](https://www.php.net/manual/en/session.configuration.php#ini.session.use-strict-mode) is enabled? We currently don’t support strict mode

1 Like

Again, thanks a lot for the response.
That’s exactly what it was, I de-activated strict mode and now it works.
Thanks so much, very impressive app!

Might it be useful to have a notification about strict mode in the installation requirements? My host has strict mode activated by default for example.

Yes, we should add that to the docs. I think there is some work on the code we can do as well.

I have the exact same problem fxk had.
Iam not able to set [session.strict_mode] off because I could not change the php.ini.

I read in your referenced link that the [session.strict_mode] should not set disabled. Could you explain why it have to to login to leantime? I would like to test this and everything (install … ) run well until this error. Took me 2 hours to find any hint and just found this forum post.

Could you fix it in the code?

Edit: If someone have the same issue…

I contacted my hosting-company and they put ini_set('session.use_strict_mode', false); after <?php in the public/index.php and it is working now!