PHP Fatal error after install

Hello,

I have installed Leantime on MacOS, PHP 7.2 MYSQL 5.7 after completing install script and logging in I get a 500 error. I took a look at the error log, and there is this error message:

PHP Fatal error: Uncaught PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'zp_projects.psettings' in 'field list' in /Users/mrp/Sites/leantime/src/domain/projects/repositories/class.projects.php:357

Is there a table or column missing from the DB?

Thanks,
Matt

I had the same error 500 after installing Leantime version 2.1.5.
Apache
Ubuntu 20.04
Php 7.4

[Sat Jan 30 01:00:02.822515 2021] [php7:error] [pid 16792] [client 177.25.210.84:11478] PHP Fatal error: Uncaught PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘zp_projects.psettings’ in ‘field list’ in /var/www/html/leantime/src/domain/projects/repositories/class.projects.php:357\nStack trace:\n#0 /var/www/html/leantime/src/domain/projects/repositories/class.projects.php(357): PDOStatement->execute()\n#1 /var/www/html/leantime/src/domain/projects/services/class.projects.php(33): leantime\domain\repositories\projects->getProject()\n#2 /var/www/html/leantime/src/domain/projects/services/class.projects.php(379): leantime\domain\services\projects->getProject()\n#3 /var/www/html/leantime/src/domain/projects/services/class.projects.php(339): leantime\domain\services\projects->changeCurrentSessionProject()\n#4 /var/www/html/leantime/src/core/class.application.php(88): leantime\domain\services\projects->setCurrentProject()\n#5 /var/www/html/leantime/public/index.php(41): leantime\core\application->start()\n#6 {main}\n thrown in /var/www/html/leantime/src/domain/projects/repositories/class.projects.php on line 357, referer: https://leantime.ginux.online/

in database the table : [zp_projects] the table doesn’t really have that field psettings

I added the field and everything works perfect

ALTER TABLE zp_projects ADD psettings VARCHAR (255) NOT NULL AFTER active;

Is varchar??

Hey, sorry seems there is an issue in the installer, I’ll update and release a fix today.

Hey All,

Fix just went out and the docker image is building. 2.1.6 has a fix for the issue mentioned