Leantime taking too long to create things

Hi all.

I have a problem creating tasks, milestones, ideas, retrospectives, etc, it takes over 1 minute and a half to do this process and not sure why could be wrong.

I am working under a fresh install of 2.1.4 version (downloaded the zip).

I am using ubuntu 18.04.1 with Apache2
PHP 7.2.31-1
Using FPM for vhost with pool management.

My system is running at https://management.codetica.com
And php info can be seen under https://management.codetica.net/info.php

Everything else (first boot and installation, deleting tasks, renaming, changing status and updating) works perfectly fine, but when I create something takes too much time:

And my vhost configuration looks like this:

<VirtualHost *:443>

ServerName management.codetica.net

ServerAlias www.management.codetica.net

DocumentRoot /var/www/codetica.net.management/public_html/public/

<Directory /var/www/codetica.net.management/public_html/public/>

    Allow from all

    AllowOverride All

    Require all granted

</Directory>

<FilesMatch ".php$"> 

    SetHandler "proxy:unix:/var/run/php/php7.2-fpm-management.sock|fcgi://localhost/"          

</FilesMatch>

LogLevel warn

ErrorLog /var/log/apache2/error_management.log

CustomLog /var/log/apache2/access_management.log combined

Include /etc/letsencrypt/options-ssl-apache.conf

SSLCertificateFile /etc/letsencrypt/live/management.codetica.net/fullchain.pem

SSLCertificateKeyFile /etc/letsencrypt/live/management.codetica.net/privkey.pem

Already checked apache, mysql and php logs, and no errors were found.

I appreciate a lot any help that could be given.

Thanks.

If anybody gets this issue in the future, I changed $useSMTP to false in config file and now everything works like a charm.

1 Like

Thanks for following up on this.

If anybody gets this issue in the future, I changed $useSMTP to false in config file and now everything works like a charm.

Thank you! Worked for me as well. It seems the Leantime don’t send e-mails in paralel, but it’s doing right after the action in database.

Hi All,

Correct it’s a serial task. Make sure your smtp server is accessible. And that your credentials are correct.

I can take a look and see if there is an option to parraralize the task.