Installaition on Webspace leads to false redirection

Yesterday I installed Leantime on my private Webspace (hosted by netcup.de) without any problems.
Today I tried to install it on a different Webspace (hosted IONOS by 1&1) and noticed the following Problems:

  • the URL/install does not work
  • URL/index.php?install=true works but when I insert the Userdata I’m redirected to URL**//**install which leads to an 404 error

I checked if mod_rewrite is active and it seems to work.
The Subdomain leantime.URL.de leads to the public Folder
I used different ways to upload the leantime-files: I uploaded the zip and extracted it on the server; i uploaded the files from my linux laptop via ftp and I also tried to upload the files from my privat-server with the working installation.

Where can I find out, what rights the files should have? The files that I extracted from the zip all have 666, on my other server they have 644 and the files i uploaded via ftp have 604. What is right?

Do you have any suggestions what I could try to make leantime work? I really would love to use it on this second server…

Greetings
Moritz

This was the solution: